View Single Post
Old
  (#3)
CrossBone Cue
AzB Gold Member
CrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond reputeCrossBone Cue has a reputation beyond repute
 
CrossBone Cue's Avatar
 
Status: Offline
Posts: 491
vCash: 500
iTrader: 12 / 100%
Join Date: Mar 2014
   
07-06-2014, 12:33 PM

I read your earlier post on the lid, already have it off for now. I have a high tower lathe so I am good on the tips, shafts. Guess I will figure out a router bracket to cut down forearms. I put it back together this morning and fired it up, Still works perfect. I took off the motor and put it in the over for an hour on 100 degrees to remove any moisture.
Anyone have any tooling that would fit this one or is there a way to convert it to a more modern tooling set up? also need a chuck, I went on logan actuators website and found some stuff, but didn't know if anyone on here had anything. Belts are shot for sure.
steve


Shooter-Flipping Broom Stick right now(with Skulls)
Break-Auerbach Ebony
Shooting Time-2-3 hour a week

https://www.facebook.com/profile.php...054&fref=photo



Last edited by CrossBone Cue; 07-06-2014 at 01:14 PM.
  
Reply With Quote