View Single Post
Can someone help me figure out what's wrong with my shaft and what's causing this dis
Old
  (#1)
tjlmbklr
AzB Silver Member
tjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond reputetjlmbklr has a reputation beyond repute
 
tjlmbklr's Avatar
 
Status: Offline
Posts: 1,769
vCash: 500
iTrader: 16 / 100%
Join Date: May 2005
Location: Milwaukee
   
Can someone help me figure out what's wrong with my shaft and what's causing this dis - 03-18-2019, 04:54 PM

Sorry for the botched title, I ran out of letters.

I have owned about a dozen cues and I have always been very meticulous with my shaft care and have never seen this issue. I bought this Meucci pro as a partial blank and had Schmelke cues custom make a cue for me. I know they have to put their finish on it as well as 'The Pro' sticker before the finish coat, but I don't know is this issue is something they did or if it's a defect from Meucci. As you see but the pics/video there are uneven areas that get dirty very fast, this is even with a seal of wax on it. It also only takes a few hours of play for it to appear.

https://imgur.com/a/rSDLoa7

Thanks.

Sent from my ONEPLUS A6013 using Tapatalk


"Luck is the residue of good practice"

-Unknown

Last edited by tjlmbklr; 03-18-2019 at 04:56 PM. Reason: Botched title
  
Reply With Quote