Mach 3 Safe Z Question

scdiveteam

Rick Geschrey
Silver Member
Hi,

When I set and save my Safe Z parameters it works but I want my first move of the routine to raise the Z to .050.

Can anyone help me do that.

Thanks in advance,

Rick
 

kgoods

AzB Gold Member
Gold Member
You should be able to also set your safe Z in your CAM program. My CAM program allows for a rapid safe Z for avoiding clamps etc., and a second safe Z that allows for rapids down to a Z value before the cut to save time. Not sure what you're using so I can't really help much. But look into G98 and G99 codes and how they are handled in your CAM program and see if that helps.
If nothing else, just edit your file after it's created and add the Z move you need prior to the start of normal programming. If you need help with that, post the first 10-15 lines of the file and I'll try to help.
What are you actually trying to accomplish?
 

ELBeau

AzB Silver Member
Silver Member
Sounds like you're saying you want to set a different "Rapid Height" in your program as opposed to a "Safe Z." As previously mentioned, you should be able to set that in your CAM program or just manually edit the Gcode.

We never did hear any feedback the last time you asked for help with your Mach3 display table https://forums.azbilliards.com/showthread.php?t=512318 :confused:
 

scdiveteam

Rick Geschrey
Silver Member
Sounds like you're saying you want to set a different "Rapid Height" in your program as opposed to a "Safe Z." As previously mentioned, you should be able to set that in your CAM program or just manually edit the Gcode.

We never did hear any feedback the last time you asked for help with your Mach3 display table https://forums.azbilliards.com/showthread.php?t=512318 :confused:

Beau,

I did not resolve the issue with the display. My display is now larger and to be honest, I have no idea how it stopped being so tiny.

When I load a program file it is normal size and I can make in zoom in very close without much effort with the mouse control.

Thanks for trying to help last time.

As far as this Rapid height it is not that big of an issue as I just set my zero z height at plus .010 with a .010 shim and add .010 to the depth parameter. No big deal.

When I moved to Vegas my computer operating system shit the bed and I had to go thru a lot of shit with Bobcad, Mach 3 and the Geek Squad. Kim gave me his Mach 3 file which I an now using.

When i was in Illinois my set up always had the z move up .100 before the first move and .100 safe z.

Also in Illinois with my old set up at the end of each routine, it always returned to x zero, y zero, z zero. Now I have to physically tell it go to zero every time. I run a lot of multiple programs with tool changes. I have not screwed up yet and lost my datum, but there is always that chance.🤯

I am thinking that these differences I am seeing may be in the selection of the post processor.

Again thanks for you help in the past.

Rick.
 

aphelps1

AzB Silver Member
Silver Member
Rick,
I edit my post processor to move to .7 Z before beginning a program. It's a simple one line add. PM me.

Alan
 
Top